Intermittent Errors
Incident Report for NationsBenefits
Resolved
This has now resolved.
Posted Oct 03, 2024 - 22:04 UTC
Monitoring
We are monitoring the current solution. You should see normal behavior now.
Posted Oct 03, 2024 - 21:13 UTC
Investigating
NationsBenefits is aware that some users are experiencing errors when attempting to log in or purchase from our site. These errors are intermittent and resolve within a few minutes. We are actively working to prevent any further recurrences.
Posted Oct 03, 2024 - 18:38 UTC
This incident affected: Benefits Pro Web and Benefits Pro App.